Pandemonium
Lijsterbeslaan 3
B-2940 Stabroek, Belgium
IBAN: BE78 9794 3692 5286
BIC: ARSPBE22XXX
KBO: 0314.595.348
VAT: BE 0 881.023.185
request blrootsales@pandemonium.be
ID:  Pass:    [ Not logged in. ]

 Notes on configuring Microsoft Services For UNIX (SFU) 
 Dave Driesen
Joined 2007-05-18 20:59:14.
(3632 Days old)

Notes on configuring Microsoft Services For UNIX (SFU)

Posted on: 2011-10-09 14:43:04 
IP: Logged 
I ran into a few issues the last few days while configuring Microsoft Services for UNIX, which seemed to be rather cumbersome to resolve so I'm noting some things down for future reference.

Initially it was not possible to use ssh to connect to the Interix subsystem.This is because the remote shell provided by Microsoft does not provide SSH connectivity (despite mentioning of the contrary on some MS webpages). This was solved by installing the Power User pack from http://www.suacommunity.com/SUA.aspx and several packages from ftp://ftp.interopsystems.com/pkgs/3.5-x86.

Permission Denied while logging on through ssh
After installing and configuring OpenSSH, some users were capable of logging on through ssh but others weren't. They simply received the message "permission denied" regardless of the fact that they had entered the correct password. Running sshd in debug mode did not yield any helpful information. I resolved the issue by assigning the "Log on locally" privilege in the Domain Controller Security Policy as the server running SFU in this case is a DC. Without this privilege, users were not able to log on.

ssh logon hangs while logging on through ssh
Some users did not receive the "Permission denied" message but their ssh session would hang indefinitely on logon. Logging on to the windows box once using the user's account solved this issue.

Other helpful commands:
I am partial to using bash, so to change this you need to run:
net user /USERCOMMENT:"/bin/bash" /DOMAIN

Long delay when launching Midnight Commander (mc)
I'm also partial to mc.. However, as I had previously experienced on one of our debian boxes, there was a fifteen second delay each time a user launched mc.On the debian box, this was due to a DNS issue or something or other pertaining to resolv.conf so I spent quite some time searching in that direction. On the Interix box however, it turned out to be the fact that the DISPLAY variable was set and mc was consequently searching for an X server to connect to. The problem was solved after clearing the DISPLAY variable. you can test this by executing:
"DISPLAY= mc" (mind the space: DISPLAY=[space]mc)

No colors in Midnight Commander (mc)
At the moment, launching mc gives me a monochrome display instead of the trusty blue color layout.
For now, this can be solved by launching midnight commander as follows: mc -c


  Showing entry "Notes on configuring Microsoft Services For UNIX (SFU)".
Pandemonium 2009


These pages are the intellectual property of the Pandemonium crew.
Welcome to Pandemonium.be - Antwerp based development studio providing development and administration services. Developers and maintainers of the Pyromasaur 3D framework.
Secure
"